"Enter"a basıp içeriğe geçin

‘ReferenceError: primordials is not defined’ Hatası ve Çözümü

Eski bir projede gulp çalıştırırken böyle bir hata ile karşılaştım.  Gulp 3. versiyonu Node 12. versiyon ile birlikte çalışmıyormuş. Daha detaylı açıklamayı kaynaktan okuyabilirsiniz. Sorunun çözümü için iki yöntem var.

1 ) Gulp versiyon 4’e güncelleme yapmak. Çok uğraştıracağı için ben bu yöntemi tercih etmedim. Ama kesin çözüm istiyorsanız bunu yapmanızı tavsiye ederim 🙂

2 ) package.json dosyamızın olduğu dizinde npm-shrinkwrap.json diye bir dosya oluşturalım.  İçerisini şu şekilde dolduralım.

{
  "dependencies": {
    "graceful-fs": {
        "version": "4.2.2"
     }
  }
}

En son olarak npm install yaptıktan sonra gulp’ı kullanmaya başlayabiliriz.

 

Kaynak :

https://timonweb.com/posts/how-to-fix-referenceerror-primordials-is-not-defined-error/

Bir Cevap Yazın

%d blogcu bunu beğendi: